GolfBuddy Knowledgebase

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  • No Satellite Signal

    • Please note: You are unable to acquire satellite reception while indoors - please make sure you are outside or on the golf course.

    • While on the golf course make sure you have an unobstructed view of the sky. Please head to the tee box.

    • Initial satellite connection may take up to 15 minutes; please note that weather may affect the signal strength.

    • If you are still experiencing issues, please sync your unit to the GB Manager program and update the firmware and course database. For instructions on syncing with GB Manager, click link below: http://help.golfbuddyglobal.com/.

    • If you are still experiencing issues : Service Request Registration 


    URL : http://help.golfbuddy.com/sList.asp?searchproduct=32&searchcategory=8&seq=1596&page=1&searchtext=
  • No Course Layout

    [Summary of issue faced]

    • No Course Layout

     

    [Root Cause]

    • Some course layout files don’t exist in the internal memory, due to the mistakes during the production or unknown reason during the usage.

     

    [Solution]

    • This issue can be solved by coping all of the missed files to the memory again. 

      1. Connect the WTX to your computer via USB cradle.

      2. Run the GBManager or G3Mac, and go to the “Step3”.

      3. Check the country where the golf course is located.

      4. Press the button “Next” and check the “All courses(Overwrite)” in the popup.

      5. Press “OK” button to finish updating the course data.

       

     

      6. After the course update, disconnect the WTX from your computer.

     


    URL : http://help.golfbuddy.com/sList.asp?searchproduct=32&searchcategory=8&seq=1647&page=1&searchtext=
  • About Trouble shooting for GPS issue

    [Summary of issue faced]

    • Can't find a course even around tee box of the 1st hole

    Stop at the below screen showing 2GC or 3GC, etc

     

    Wrong yardage

    Failure of automatic hole change

    turned off during playing the round

    [Root Cause]
    All of problems is caused by the poor performance GPS
    (Poor GPS would bring more consumption of battery)

     

    [Solution]

      Do the GPS reset in case you would encounter this issues

        How to do the GPS Rest
        a) From Golf Mode, press and hold anywhere on the screen over 4 seconds to exit the game.

        b) Tap the button  to do the "GPS reset"

        c) After finding satellites, WTX will return to the main screen.

           
     

     


    URL : http://help.golfbuddy.com/sList.asp?searchproduct=32&searchcategory=8&seq=1646&page=1&searchtext=
  • WTX can't be turned on

    [Summary of issue faced]

    • WTX can’t be turned on.
    • The battery icon can’t be shown in the screen during charging.

    ​[Root Cause]

    • In case the battery of WTX would be discharged fully, it would take 2minutes ~ over 1 hour for the battery icon to be shown after the charging, according to how long the WTX has been discharged.

    • For this case, it seems that WTX can’t be turned on or can’t be charged.

     

    [Solution]

    • When WTX can’t be turned on or can’t be charged, please make WTX stay on the charging cradle for enough time.

    Important Notice

    All of WTX shouldn’t be classified as the faulty one until you wouldn’t see the battery icon even after enough charging time. 


    URL : http://help.golfbuddy.com/sList.asp?searchproduct=32&searchcategory=8&seq=1641&page=1&searchtext=
  • Blutooth Troubleshooting

    [Summary of issue faced]

    • After successful connecting the WTX to your Android smartphone, the following issues happen
    1. “Find Me” from your smartphone works fine
    2. “Fine Phone” from your WTX doesn’t work normally
     

    3. Your WTX doesn’t receive any notifications from your smartphone.
    4. Notification received on WTX doesn’t vibrate.
    5. Notifications were not saved on WTX

     

    ​[Root Cause]

    • Android bluetooth stack will enter the abnormal state when the disconnection from WTX will not be done normally.
    • Afterwards, there might be abnormal behavior during bluetooth communication.

     

    [Solution]

    ​• Make both of your smartphone and WTX reset to fix this issue.
     1. How to reset your WTX

     

     

    2. How to reset your smartphone.


    [Samsung smartphone]
    ​ ​1) Go to the “Settings’ and select the “General management”. 

       

     2) Select “Reset” → “Reset network settings”

       

     3) Tap the button “RESET SETTING” →”RESET SETTINGS”
         

    [LG smartphone​]

     1) Got to “Settings” → “General” → “Backup & reset” → “Network settings reset”

       

    ​ 2) Tap the button “RESET SETTINGS”.

       

    [Sony smartphone]

    https://www.youtube.com/watch?v=H5cx4uPWw2E


    [Others’ smartphone]
    Refer to the manual for “reset network settings”.


    URL : http://help.golfbuddy.com/sList.asp?searchproduct=32&searchcategory=8&seq=1642&page=1&searchtext=
  • Moisture On Screen • If you are still experiencing issues : Service Request Registration
    URL : http://help.golfbuddy.com/sList.asp?searchproduct=32&searchcategory=8&seq=1459&page=1&searchtext=